Ask Us! Missing Blackberry Browser

Missing Blackberry Browser
Kate asked us,

I upgraded my Blackberry OS after following the instructions to install the Zen theme. The theme is neat but after awhile I found out I was missing my browser. Thinking it was something to do with the theme, I switched back to my old theme and my browser is still missing! Any ideas?

This is actually a common occurrence when upgrading the operating system on the Blackberry handheld. It is an easy fix for the most part, just do the following:

1. Options -> Advanced Options -> Host Routing Tables.

2. In this screen you may see several entries, ignore the others and highlight the bold entry.

3. Wheel-click and select ‘Register Now’.

4. Close the screen and go back to the Home Screen. Give about 30 seconds for your browser to reappear.

38 Responses to “Ask Us! Missing Blackberry Browser”


  1. 1 HEEELLLPPP!!

    HEEELPPP!!
    I can’t figure out where to leave a message…
    I’m receiving a JVM 544 error message on my 7100g after I tried installing a theme from this website.. WHAT DO I DO? I can’t use my phone and I do not have another one!
    Please.. HELP!!!

  2. 2 Adam

    Thank you!!
    ** Missing Blackberry Browswer **
    WORKED GREAT — Thanks for you help!

  3. 3 John

    Thank You, I felt lost without the browser. The fix worked like a champ!

    ** Missing Blackberry Browswer **

  4. 4 annoyed user

    Hi,

    I am using vodafone and this doesn’t work ! :(
    Any idea?

  5. 5 Jeff

    Thank you so much! This was so simple, I am so glad there is a resource like this. I was freaking out without my browser!

    Jeff

  6. 6 Hippy Joe

    Worked Great! Thanks Again

  7. 7 Crystal

    OH THANK YOU! This has been bothering me all morning!!!

  8. 8 miriam

    I just get the blackberry pearl and I can’t see the browser for the internet and I try to do what you said on this sitge but the icon didn’t appear. I also have a error message that appear in the help button and said this: “Error Starting net_rim_bb_help: Module net_rim_ecmascript not found.” ….WHAT CAN I DO!!!!!! I really like this cel but I need the browser…PLEASE HELP ME

  9. 9 Michael Oryl

    Worked perfectly with a Verizon branded 8830. There were dozens and dozens of entries in the table, but I eventually found the bolded one. Thanks.

  10. 10 Steve

    Hi, i’ve just got a blackberry 7100i and i cant find the browser, i’ve tried the following:
    1. Options –> Advanced Options –> Host Routing Tables.

    2. In this screen you may see several entries, ignore the others and highlight the bold entry.

    3. Wheel-click and select ‘Register Now’.

    4. Close the screen and go back to the Home Screen. Give about 30 seconds for your browser to reappear.

    i just received a message saying that the handheld has been registered, but the browser didn’t appeared.

    Thanx

  11. 11 Lloyd

    WHAT is a “Wheel-click”?

    Needless to say, I’m new to the BlackBerry. When I click the trackball on the bold entry, I get a description of the CDMA entry, but no option to “register now”.

  12. 12 Lloyd

    Nice to know someone’s moderating this list….NOT.

  13. 13 BlackBerry Cool

    Easy Lloyd,

    First tell us what type of CDMA BlackBerry you are using, and what else you see besides the description.

    Also, what BlackBerry OS are you using (i.e. what version number?)

  14. 14 Debbie Kurth

    THANK YOU! You saved me from hours and hours of work.
    Using BlackBerry 8700g and installed the upgrade OS. The install crashed, but was able to restore data from backup (VERY IMPORTANT TO SAVE). After which, the new OS looks rather cool, but I was missing the browser.
    THANKS AGAIN.

  15. 15 logicool1

    Thanks, so much. Browser was back 15 seconds after reading your entry.

  16. 16 amazed.

    GENIUS! thank you! I tried for an hour to get the browser back and finally resulted to google.

  17. 17 Amr Ibrahim

    I can’t see the browser for the internet and I try to do what you said on this sitge but the icon didn’t appear. I also have a error message that appear in the help button WHAT CAN I DO ??? I need the browser…PLEASE HELP ME

    please quickly

  18. 18 drexel olasin

    I am trying to upgrade my blackberry 7290 and installing the idokorro admin but suddenly my device pops up with JVM Error 544 and Reset.What should I do?

  19. 19 Talena

    I have a blackberry 7280 and under advanced options my list is blank, what can i do? Please help. thanks

  20. 20 kattalien

    I have a blackberry 8700G.

    I went to options and under advanced options.

    I clicked on Host Routing Table.

    There are no entries in the HRT Editor.

    my list is blank,

    what can i do?

    Now, I can NOT get the web browser.

    Please help.

    thanks

  21. 21 james

    ditto with kattalien

  22. 22 Elliott

    Kattalien/James -

    If your list is blank, click the Blackberry button, sometimes I call it right-clicking, to bring up the options. You’ll see the option to register there!

    -ek

  23. 23 Nathan Edgell

    Amazing fix! My first 8100 got smashed, so I got another one and had no browser, tried EVERYTHING! Never would have figured that out!!! Thank you so so so much! Now if I could just figure out my enterprise activation info I’ll be set…

  24. 24 Leticia

    I have the same problem that Kattalien had. I tried to fix it per your directions but nothing happened. I have a pearl from At&T, the mediamall is also missing. Please help. I can’t browse or receive multimedia messages.

  25. 25 tony

    I TRIED REGISTERING THROUGH HRT AND IT SAID THAT REGISTRATION WAS SENT.WAITED AND STILL DID NOT SEE ANY BROWSER ICON.ALL I SEE ON MY HOME SCREEN IS DATA CONNECTION REFUSED.PLS HELP.

  26. 26 Paul

    @tony

    You need to have your service provider send you the service books again. Go to Options->Advanced->Service Books. You can delete all the books except the provisioning one which should be locked. After you delete them first try to register the HRT. If that doesn’t work (and sometime it doesn’t work for me) either login to the blackberry services for your phone and send the service books from there or call your service rep and have them do it. You may have to wait for 30 - 60 minutes (my experience) before you have everything again.

    The other thing I’ve noticed is that if you have a password set in security, the browser can get screwy. This is the technical term meaning you should disable the password to test and see if it comes back. A battery removal reset might be in order if no immediate results occur but don’t forget to turn off the phone first before doing that.

    Paul

  27. 27 pllyles

    I still wasnt able to get my browser icon to appear

  28. 28 phool chand

    lost my blackberry browser

  29. 29 Shawn Murphy

    I tried the quick fix to relocate/enable my bowser and when I got into the Host Routing Table page, it was blank. What does that mean?

  30. 30 nikkiberry

    is the medianet browser same as the blackberry browser? i tried to look for the blackberry browser and did the hrt suggestion and i got a message saying i was registered but no new browser icon appeared… so.. is there something wrong? im on the unlimited data plan for blackberry. thanks

  31. 31 Derek

    THIS GUY IS GOOD!

    THANKS

  32. 32 Alex Quintanar

    Thanks, this help my life

  33. 33 daf

    hi im trying to also locate my browser and i did wat u suggested but its not working for me, wat else shud i do

    plz help

  34. 34 d brown

    Thanks so much! This actually worked. I had spent an 1 hour on the phone with tech support, then another hour in the Verizon store and no one could fix it. They told me that the only thing they could do was ship me another phone. So I decided to google it and luckily found this site. Verizon Wireless customer service, wireless data support, and in-store technicians suck!

  35. 35 Rick Leigh

    works like a charm….reset browser is OK now

  36. 36 Curtis

    I dosen’t work for me cause my Host Routing Table is empty and even if i register it never sends me the message! I even have a video on YouTube if you know how to fix this problem please!!! HELP ME!

  37. 37 Z Storm

    I have a blackberry storm and this solution did not work. Upon re-registering, I got a message saying I’ve registered - No icon. I then took out the battery for 30 seconds and brought the device back up - still no icon. Note that on restart when the home page first showed, I got an unhandled exception error but clicked OK and continued as normal. Help please.

  38. 38 Z Storm

    I figured this one out. I went to themes, clicked menu button, selected Reset Theme Defaults, and it went back to my Verizon home screen photo and the browser icon was back! I was then able to change my home screen image and settings back to what I wanted. Don’t know why I never tried this prior, perhaps because I only have one theme?!?!?

Leave a Reply




Close