QuickPlayer officially launched

Comments

quickplayer.jpg

We gave you a brief look at the QuickPlayer from QuickPlay a couple months ago after our trip to CTIA, and we got a little excited then. We’re even more excited now that it’s been officially launched and made its way into the BlackBerry world. The application streams audio content from your favourites like the Wall Street Journal, ABC News, and over 100 more channels to choose from. The service’ll set you back a mere $7.95 a month and it’s available on the BlackBerry 7130e, 8700 series, and Pearl (for now). Check out the video we churned out for the QuickPlayer just after the jump. Congrats, QuickPlay.

  • Willassa

    I’m using the 8707v and what I get is:
    Sorry your device is not supported for QuickPlayer application.

    Merry Christmas :-)

  • Willassa

    I’m using the 8707v and what I get is:
    Sorry your device is not supported for QuickPlayer application.

    Merry Christmas :-)

  • LaDon

    I am using the blackberry pearl and I get the same response…sorry your device is not supported for quickplayer application

  • LaDon

    I am using the blackberry pearl and I get the same response…sorry your device is not supported for quickplayer application

  • Amberish

    Am also using 8707v and got the device not supported error message. The Quickplayer website says that it shoud work on 8700 series. Doesn’t 8707v fall in that series? And to top it off, the FAQ website doesn’t give any application requirement details. :(

  • Amberish

    Am also using 8707v and got the device not supported error message. The Quickplayer website says that it shoud work on 8700 series. Doesn’t 8707v fall in that series? And to top it off, the FAQ website doesn’t give any application requirement details. :(

  • Amberish

    Am also using 8707v and got the device not supported error message. The Quickplayer website says that it shoud work on 8700 series. Doesn’t 8707v fall in that series? And to top it off, the FAQ website doesn’t give any application requirement details. :(