OS 4.5 now officially available via BlackBerry.com/Upgrades (UPDATE)

View Comments

UPDATE 2: This updating method will only work for non-BES BlackBerry users. Any BIS users out there, please post a comment and let us know if the update works, and which device you are using!

UPDATE: Looks like BlackBerry 8330 users are still out of luck. Sorry guys! (Thanks, Nan)

Oh sweet glorious day! There have been a variety of BlackBerry Nation members who have been suffering through news about new BlackBerrys and OS 5.0 features, when all they want is OS 4.5 to be released by their carrier. Wait no more: http://www.BlackBerry.com/Upgrades is now live, allowing you to upgrade your OS directly from RIM.

You’ll need to use Internet Explorer and click “UPGRADE NOW” to download the 25MB ActiveX control which is essentially a watered down version of Desktop Manager. At the end of the process you can enter in your email address to be notified of any future OS upgrades.

Note: If you had already installed another carrier’s version of OS 4.5, you’re going to have to downgrade to a lower OS version before installing the proper one (thanks Al).

(via BerryReview)

  • Jonathan

    Correct link is. BB did not want to parse the upcase U for some reason.

    http://www.BlackBerry.com/upgrades

  • Jonathan

    Correct link is. BB did not want to parse the upcase U for some reason.

    http://www.BlackBerry.com/upgrades

  • Richard Puckett

    No love for AT&T 8800 4.2.1. No official 4.5 for it yet - the ActiveX control seemed to work well otherwise though. Signed up to receive an email. I shall commence holding my breath.

  • Richard Puckett

    No love for AT&T 8800 4.2.1. No official 4.5 for it yet - the ActiveX control seemed to work well otherwise though. Signed up to receive an email. I shall commence holding my breath.

  • Richard Puckett

    No love for AT&T 8800 4.2.1. No official 4.5 for it yet - the ActiveX control seemed to work well otherwise though. Signed up to receive an email. I shall commence holding my breath.

  • Richard Puckett

    No love for AT&T 8800 4.2.1. No official 4.5 for it yet - the ActiveX control seemed to work well otherwise though. Signed up to receive an email. I shall commence holding my breath.

  • http://yettas.com/ pete

    ATT, Pearl 8100 here.. The installer says I am “up to date”, though running 4.2.x .. meanwhile, blackberry.com says my carrier “does not support 4.5″. :(

  • http://yettas.com pete

    ATT, Pearl 8100 here.. The installer says I am “up to date”, though running 4.2.x .. meanwhile, blackberry.com says my carrier “does not support 4.5″. :(

  • Bryan

    So what’s the benefit of me installing this 4.5 as opposed to my current v4.5.0.52 that I grabbed about two months ago. Is this a newer version of the 4.5 OS, or is it just the US release of the same OS that’s been out for a while?

    Thanks!

  • Bryan

    So what’s the benefit of me installing this 4.5 as opposed to my current v4.5.0.52 that I grabbed about two months ago. Is this a newer version of the 4.5 OS, or is it just the US release of the same OS that’s been out for a while?

    Thanks!

  • Aaron

    My 8310 on AT&T running v2.2.2.170 is apparently up to date.

    Bummer.

  • Aaron

    My 8310 on AT&T running v2.2.2.170 is apparently up to date.

    Bummer.

  • Nick

    No luck with Tmobile’s 8320. It advised me that my software was already up to date.

  • Nick

    No luck with Tmobile’s 8320. It advised me that my software was already up to date.

  • Drew

    Alas, T-mobile 8320 is a no go too. 4.2 appears as up to date.

  • Drew

    Alas, T-mobile 8320 is a no go too. 4.2 appears as up to date.

  • Ken

    AT&T Curve 8310 - says that 4.2.2.170 (platform 2.5.0.30) is up to date…Updater software loaded nicely on my Vista machine.

  • Ken

    AT&T Curve 8310 - says that 4.2.2.170 (platform 2.5.0.30) is up to date…Updater software loaded nicely on my Vista machine.

  • http://beyondthebleedingedge.blogspot.com/ Andrew

    No Joy - 8100 on Rogers.

  • http://beyondthebleedingedge.blogspot.com/ Andrew

    No Joy - 8100 on Rogers.

  • Jwt0001

    8130 on Verizon not updated.

  • Jwt0001

    8130 on Verizon not updated.

  • Jay

    no luck with my 8300

  • Jay

    no luck with my 8300

  • Dan

    Apparently my ATT Curve 8310 software is up to date and will not load 4.5, even though my current OS is v4.2.2.170

  • Dan

    Apparently my ATT Curve 8310 software is up to date and will not load 4.5, even though my current OS is v4.2.2.170

  • ji

    telus pearl 8130 says software is up to date, but i am running v.4.3

  • ji

    telus pearl 8130 says software is up to date, but i am running v.4.3

  • clexman

    No luck for my Sprint 8703e 4.2 device… I’ve had this thing almost 2 years and the only upgrade available is the 8800 that only adds video playback and just about nothing else useful.

    When oh when will the 8900 and up generation come to Sprint?!

  • clexman

    No luck for my Sprint 8703e 4.2 device… I’ve had this thing almost 2 years and the only upgrade available is the 8800 that only adds video playback and just about nothing else useful.

    When oh when will the 8900 and up generation come to Sprint?!

  • JustDewIt

    Just go to the normal download site on blackberry.com, and choose Europe’s Trigcom as your carrier. Official 4.5 releases for most models! Works fine on AT&T, even if they don’t “officially” support it yet.

  • JustDewIt

    Just go to the normal download site on blackberry.com, and choose Europe’s Trigcom as your carrier. Official 4.5 releases for most models! Works fine on AT&T, even if they don’t “officially” support it yet.

  • JustDewIt

    Just go to the normal download site on blackberry.com, and choose Europe’s Trigcom as your carrier. Official 4.5 releases for most models! Works fine on AT&T, even if they don’t “officially” support it yet.

  • Krzysztof

    I have AT&T and it just tells me that 4.5 isn’t available for me yet. Filled out a form though to notify me.

  • Krzysztof

    I have AT&T and it just tells me that 4.5 isn’t available for me yet. Filled out a form though to notify me.

  • Chris

    Same here with my AT&T 8300. No dice on 4.5 upgrade. Still running v4.2.2.166 is “up-to-date” according to the utility.

  • Chris

    Same here with my AT&T 8300. No dice on 4.5 upgrade. Still running v4.2.2.166 is “up-to-date” according to the utility.

  • artie

    Sprint 8130 4.3 up to date.

  • artie

    Sprint 8130 4.3 up to date.

  • SUGE WHITE

    Anyone update sprint 8830? Im running a 4.5.051 on mine now. Is it worth the time?

  • SUGE WHITE

    Anyone update sprint 8830? Im running a 4.5.051 on mine now. Is it worth the time?

  • Chris M

    I’d love to know how you got 4.5 on your Sprint 8830. I’ve been trying for a long time and this upgrade site is worth about as much as a wet paper sack :p

  • Chris M

    I’d love to know how you got 4.5 on your Sprint 8830. I’ve been trying for a long time and this upgrade site is worth about as much as a wet paper sack :p

  • Chris M

    I’d love to know how you got 4.5 on your Sprint 8830. I’ve been trying for a long time and this upgrade site is worth about as much as a wet paper sack :p

  • SUGE WHITE

    chris….it could be arranged? You on pinstack.com?

  • SUGE WHITE

    chris….it could be arranged? You on pinstack.com?

  • SUGE WHITE

    chris….it could be arranged? You on pinstack.com?

  • Chris M

    I am not… I am on Blackberryforums.com, though
    liganimc…

  • Chris M

    I am not… I am on Blackberryforums.com, though
    liganimc…

  • Chris M

    I am not… I am on Blackberryforums.com, though
    liganimc…

  • Jason

    word is its going to be another month (october 20) for t-mobile subs

  • Jason

    word is its going to be another month (october 20) for t-mobile subs

  • Heather

    No love with Bell either…. According to the desktop manager it is already up to date and when I go through the upgrade from BlackBerry’s web site all I get for the effort is a fatal error.

  • Heather

    No love with Bell either…. According to the desktop manager it is already up to date and when I go through the upgrade from BlackBerry’s web site all I get for the effort is a fatal error.

  • Heather

    I forgot to mention that it’s an 8130 that I am using

  • Heather

    I forgot to mention that it’s an 8130 that I am using

  • Heather

    I forgot to mention that it’s an 8130 that I am using

  • david

    no luck with the bb pearl 8100 (AT&T). what a tease…

  • david

    no luck with the bb pearl 8100 (AT&T). what a tease…

  • david

    no luck with the bb pearl 8100 (AT&T). what a tease…

  • x

    Jason, do you have a source for that October 20th date for T-Mobile firmware?

  • x

    Jason, do you have a source for that October 20th date for T-Mobile firmware?

  • Jag

    No luck with rogers 8800.

  • Jag

    No luck with rogers 8800.

  • http://tim.brogdon.net/ Tim

    Seems Verizon is still on v4.2. Since you have to enter your device pin, it re-directs to Verizons site, were 4.2 is the only option for my 8830.

  • http://tim.brogdon.net/ Tim

    Seems Verizon is still on v4.2. Since you have to enter your device pin, it re-directs to Verizons site, were 4.2 is the only option for my 8830.

  • http://tim.brogdon.net Tim

    Seems Verizon is still on v4.2. Since you have to enter your device pin, it re-directs to Verizons site, were 4.2 is the only option for my 8830.

  • http://tim.brogdon.net/ Tim

    Nevermind, helps when you follow the directions.

  • http://tim.brogdon.net Tim

    Nevermind, helps when you follow the directions.

  • DavidB

    VZW 8830 4.2.2.196
    No joy.

    To the person asking about 8900 on Sprint: do some reading, only CDMA devices will work on Sprint and there is no Bold/Javelin/etc. CDMA. Unless you want a Nextel 8350 there is nothing new for Sprint (yet).

  • DavidB

    VZW 8830 4.2.2.196
    No joy.

    To the person asking about 8900 on Sprint: do some reading, only CDMA devices will work on Sprint and there is no Bold/Javelin/etc. CDMA. Unless you want a Nextel 8350 there is nothing new for Sprint (yet).

  • http://tim.brogdon.net/ Tim

    Seems 4.5 does not work for 8830. I ran the upgrade then I get a message that my phone is up to date, even know I have 4.2 installed. Anyone know a work around to this?

  • http://tim.brogdon.net Tim

    Seems 4.5 does not work for 8830. I ran the upgrade then I get a message that my phone is up to date, even know I have 4.2 installed. Anyone know a work around to this?

  • ChrisJ

    Tim,
    you need to remove the vendor file from the program common files then re-install. Make sure you have an updated desktop mgr that is readily avail from BB.

  • ChrisJ

    Tim,
    you need to remove the vendor file from the program common files then re-install. Make sure you have an updated desktop mgr that is readily avail from BB.

  • Mike

    8830 on Telus .. 4.2 seems to be the latest. BAH!

  • Mike

    8830 on Telus .. 4.2 seems to be the latest. BAH!

  • clexman

    @ DavidB

    I know Sprint is CDMA, but Verizon is getting the 9530. T-mobile’s getting the flip Pearl and AT&T the Bold.

    Come on RIM I want some Sprint CDMA love!

  • clexman

    @ DavidB

    I know Sprint is CDMA, but Verizon is getting the 9530. T-mobile’s getting the flip Pearl and AT&T the Bold.

    Come on RIM I want some Sprint CDMA love!

  • DavidB

    Right clexman. 9530 is the only CDMA device we know of in the pipes. All the otheras we hear about are GSM. There is rumor of a Curve type 9xxx CDMA device in perhaps April/May/June 2009, but that’s it.

  • DavidB

    Right clexman. 9530 is the only CDMA device we know of in the pipes. All the otheras we hear about are GSM. There is rumor of a Curve type 9xxx CDMA device in perhaps April/May/June 2009, but that’s it.

  • hairyasian

    tmo 8100 (pearl) on 4.2.1.109 - no upgrade available…

  • hairyasian

    tmo 8100 (pearl) on 4.2.1.109 - no upgrade available…

  • senyorcitoninja

    Well, that’s just bs.

  • senyorcitoninja

    Well, that’s just bs.

  • Cent

    I’ve been following the comments here closely. Is it me or is no one able to upgrade to OS 4.5. On my Curve with T-Mobile, the upgrade app says my BB is up-to-date although its still on 4.2.

  • Cent

    I’ve been following the comments here closely. Is it me or is no one able to upgrade to OS 4.5. On my Curve with T-Mobile, the upgrade app says my BB is up-to-date although its still on 4.2.

  • DavidB

    Seems to be cart before horse. The upgrade app released before the carriers approved device software. And bloggers got all worked up without checking it out first.

  • DavidB

    Seems to be cart before horse. The upgrade app released before the carriers approved device software. And bloggers got all worked up without checking it out first.

  • JRO

    This upgrade does not work for branded devices (T-Mobile, AT&T, Verizon, etc.) It only works for unbranded devices as per the Blackberry rep. I talked to.

  • JRO

    This upgrade does not work for branded devices (T-Mobile, AT&T, Verizon, etc.) It only works for unbranded devices as per the Blackberry rep. I talked to.

  • Dan

    Called ATT today and finally spoke to tech rep, re: 4.5 OS on my 8310.
    He said ATT does not yet officially support OS over 4.2.2 yet, but he understood my frustration.
    “Is there anything else I can help you with today?”
    Gah!

  • Dan

    Called ATT today and finally spoke to tech rep, re: 4.5 OS on my 8310.
    He said ATT does not yet officially support OS over 4.2.2 yet, but he understood my frustration.
    “Is there anything else I can help you with today?”
    Gah!

  • hairyasian

    i just went ahead and manually installed vodaphone’s 4.5 os on my tmo pearl. it was quite glitchy for some time… kept crashing and rebooting. but i let it be for about 6 hours and it finally stabilized.

  • hairyasian

    i just went ahead and manually installed vodaphone’s 4.5 os on my tmo pearl. it was quite glitchy for some time… kept crashing and rebooting. but i let it be for about 6 hours and it finally stabilized.

  • Rocco

    If ATT supported OS4.5 upgrades then you may not want to upgrade your phone to maybe a “Blackberry Bold” with a new 2 year contract. I can’t help but to believe that Blackberry and ATT planned it this way.

  • Rocco

    If ATT supported OS4.5 upgrades then you may not want to upgrade your phone to maybe a “Blackberry Bold” with a new 2 year contract. I can’t help but to believe that Blackberry and ATT planned it this way.

  • youngbee

    How do you remove the vender file from the bb 8310?

  • youngbee

    How do you remove the vender file from the bb 8310?

  • akshay ghai

    i wantt to upgrade software but i am unable to download the file in india kindly guide

  • http://none akshay ghai

    i wantt to upgrade software but i am unable to download the file in india kindly guide

  • Kent W.

    I did go to the BB site and followed the ugprade procedure to get my 8310 Curve to 4.5.0.81 (currently running 4.2.2.163 on Rogers Wireless). The upgrade procedure had me download the BB Application Loader.

    Following the process…it detected my firmware, identified 4.5.0.81 to be the update, backed up my data, and then before it even started to change any of the data on by Curve, I get a “fatal error” message from BB Application Loader.

    Retried a few times and appears it “breaks” at the same place.

    I found another link on Google which points me to a f/w release 4.5.0.108 for Rogers Wireless customers. Looks like this updates through the BB Desktop Manager. Giving this a shot now.

  • Kent W.

    I did go to the BB site and followed the ugprade procedure to get my 8310 Curve to 4.5.0.81 (currently running 4.2.2.163 on Rogers Wireless). The upgrade procedure had me download the BB Application Loader.

    Following the process…it detected my firmware, identified 4.5.0.81 to be the update, backed up my data, and then before it even started to change any of the data on by Curve, I get a “fatal error” message from BB Application Loader.

    Retried a few times and appears it “breaks” at the same place.

    I found another link on Google which points me to a f/w release 4.5.0.108 for Rogers Wireless customers. Looks like this updates through the BB Desktop Manager. Giving this a shot now.

  • Kent W.

    Update: using the 8310 Curve release 4.5.0.108 for Rogers Wireless customers and BB Desktop Manager 4.3.x worked without any problems. The complete upgrade took about 40 minutes or so.

  • Kent W.

    Update: using the 8310 Curve release 4.5.0.108 for Rogers Wireless customers and BB Desktop Manager 4.3.x worked without any problems. The complete upgrade took about 40 minutes or so.

  • Dave

    Tried updating Curve 8330 from Telus. It says by software is up to date (4.3). Anyone else have luck with this?

  • Dave

    Tried updating Curve 8330 from Telus. It says by software is up to date (4.3). Anyone else have luck with this?

  • Aamir

    I own an Unlocked Curve 8300 from RIM. Currently it’s O/S v4.2…will upgrading to v4.5 lock the device to my carrier, or will my device remail unlocked??

  • Aamir

    I own an Unlocked Curve 8300 from RIM. Currently it’s O/S v4.2…will upgrading to v4.5 lock the device to my carrier, or will my device remail unlocked??

  • http://salesby5.com/ Nan Palmero

    Update to OS 4.5 now works for Sprint - wahoo!

  • http://salesby5.com Nan Palmero

    Update to OS 4.5 now works for Sprint - wahoo!

  • edward t

    i dont see any update for sprint

  • edward t

    i dont see any update for sprint

  • Jason

    Can someone please post instructions on how to find and remove the vendor file. I feel like we will be waiting a while for AT&T to make this update available? Thanks

  • Jason

    Can someone please post instructions on how to find and remove the vendor file. I feel like we will be waiting a while for AT&T to make this update available? Thanks

  • DavidB

    @jason:
    Use the site search!

  • DavidB

    @jason:
    Use the site search!

  • buttnugget

    Try this here:

    http://forums.crackberry.com/f3/proper-upgrade-downgrade-procedure-53359/

    if you are using windows XP, right click on the “Start” button. pop up menu gives you some options. Copy and paste the item in instruction number 6 in there.

    Open the apps…. at the very bottom of the list of files, you will a folder with the exact same string with the “XML” at the end of the string. Delete that file, that is the file of Vodafone Carrier or whoevers software it is.

  • buttnugget

    Try this here:

    http://forums.crackberry.com/f3/proper-upgrade-downgrade-procedure-53359/

    if you are using windows XP, right click on the “Start” button. pop up menu gives you some options. Copy and paste the item in instruction number 6 in there.

    Open the apps…. at the very bottom of the list of files, you will a folder with the exact same string with the “XML” at the end of the string. Delete that file, that is the file of Vodafone Carrier or whoevers software it is.

  • buttnugget

    forgot to mention press the start button, and use the “Search” function, then paste the string from item number 6 in there, that will get you in to your C: drive.

  • buttnugget

    forgot to mention press the start button, and use the “Search” function, then paste the string from item number 6 in there, that will get you in to your C:\ drive.

  • Mike

    This site worked fine for me with Telus 8330 (Curve)

    http://na.blackberry.com/eng/services/devices/#tab_tab_update

  • Mike

    This site worked fine for me with Telus 8330 (Curve)

    http://na.blackberry.com/eng/services/devices/#tab_tab_update

  • 757sneakerqueen

    can you receive text msgs after download rogers os 4.5 to blackberry curve??

  • 757sneakerqueen

    can you receive text msgs after download rogers os 4.5 to blackberry curve??

  • Mike

    Updated my Curve 8300 on AT&T and it works awesome. I just needed to delete the vendor.xml file before installing. Piece of cake. I did need to get the password from my IT folks to set it back up with our enterprise server, but the upgrade was done from my desktop.

  • Mike

    Updated my Curve 8300 on AT&T and it works awesome. I just needed to delete the vendor.xml file before installing. Piece of cake. I did need to get the password from my IT folks to set it back up with our enterprise server, but the upgrade was done from my desktop.

  • Hashiman

    I updated my bb curve 8320 to os4.5 and now my screen will blackout like its goin to reset then pops back on… very annoying and I cant figure out whats wrong!!!

  • Hashiman

    I updated my bb curve 8320 to os4.5 and now my screen will blackout like its goin to reset then pops back on… very annoying and I cant figure out whats wrong!!!

  • Aaron

    Any update to 4.5 for Sprint’s 8330 yet?

  • Aaron

    Any update to 4.5 for Sprint’s 8330 yet?

  • DavidB

    @Aaron and all:
    Sprint officially released 4.5 for ALL 8xxx phones. Go download as you would any official upgrade for Sprint.

  • DavidB

    @Aaron and all:
    Sprint officially released 4.5 for ALL 8xxx phones. Go download as you would any official upgrade for Sprint.

  • http://www.blackberrycool.com/ BlackBerry Cool

    DavidB is correct, you can see the post below for info and instructions:

    http://www.blackberrycool.com/2009/02/os-45-available-for-sprint-blackberry-curve-8330-and-pearl-8130/

  • http://www.blackberrycool.com/ BlackBerry Cool

    DavidB is correct, you can see the post below for info and instructions:

    http://www.blackberrycool.com/2009/02/os-45-available-for-sprint-blackberry-curve-8330-and-pearl-8130/

  • http://www.blackberrycool.com BlackBerry Cool

    DavidB is correct, you can see the post below for info and instructions:

    http://www.blackberrycool.com/2009/02/os-45-available-for-sprint-blackberry-curve-8330-and-pearl-8130/

  • Panda

    Apparently 4.2 is still “up to date” for 8100 T-Mobile ):

  • Panda

    Apparently 4.2 is still “up to date” for 8100 T-Mobile ):

  • Panda

    Apparently 4.2 is still “up to date” for 8100 T-Mobile ):

blog comments powered by Disqus



Bad Behavior has blocked 34738 access attempts in the last 7 days.