RIM releases patch for BES PDF security threat (BlackBerry Bytes)

Comments

RIM logoRIM released a security patch earlier this week to fix a security vulnerability related to the PDF distiller in the BES’ BlackBerry Attachment Service. If left unchecked, the vulnerability would allow malicious code to be hidden within a PDF attachment to cause memory corruption or execute commands on the BlackBerry.

The security threat affects BlackBerry Enterprise Server software version 4.1 Service Pack 3 (4.1.3) through 4.1 Service Pack 6 (4.1.6) and BlackBerry Professional Software 4.1 Service Pack 4 (4.1.4). BES admins, act now! Click the link below to read RIM’s security advisory.

Vulnerabilities in the PDF distiller of the BlackBerry Attachment Service for the BlackBerry Enterprise Server