Preview the latest BlackBerry Desktop Manager for Mac

62 Comments

mac desktop summary

Inside BlackBerry has a great post up today about the latest BlackBerry Desktop Manager for Mac. This is something Mac users everywhere have been dying to get their hands on and RIM is finally delivering.

Key features that will be released with the first build include:

  • Sync your iTunes® playlists, calendars, contacts, notes and tasks
  • Add/Remove applications
  • Update your device when new software becomes available
  • Backup and restore your device data with such features like automatically scheduled backups and optional encryption (security is #1 as always…)
  • Manage multiple devices
  • It will support Mac® OS 10.5.5 and above.

Make sure to get notified of the release at BlackBerry.com/Mac. We’ll let you know as soon as a release date is set.

macdtm_addremoveapps

macdtm_syncprogress

macdtm_music

macdtm_backup

macdtm_appupdateprogress

macdtm_addremoveapps

macdtm_calendars1

Hat tip goes to LouTreize!

[Via]

  • LINDSAY

    PLEASE HURRY WITH THIS RELEASE! AS GOOD AS MARKSPACE IS, I CANNOT UPGRADE MY SOFTWARE OR INSTALL PROGRAMS! I CANNOT WAIT!

  • LINDSAY

    PLEASE HURRY WITH THIS RELEASE! AS GOOD AS MARKSPACE IS, I CANNOT UPGRADE MY SOFTWARE OR INSTALL PROGRAMS! I CANNOT WAIT!

  • Michael

    What’s up with it requiring Mac OS 10.5.5? My wife is already steamed about this – she has an iPhone, and can not sync with her iBook, because it is a few years old. Her iBook will not even run the 10.5.5 OS, because it requires a certain speed of processor. You cannot even install 10.5 on it.

    She has to sync her iPhone, to do updates for the iPhone, on my old Toshiba notebook, running an old copy of WinXP Home.

    She is not going to buy a brand new iBook/MacBook, just to sync her phone. I would like to be able to run this software, on her iBook, for when my old Toshiba eats it, which is probably soon. RIM, do you really need to require Mac OS 10.5.5?

  • Michael

    What’s up with it requiring Mac OS 10.5.5? My wife is already steamed about this – she has an iPhone, and can not sync with her iBook, because it is a few years old. Her iBook will not even run the 10.5.5 OS, because it requires a certain speed of processor. You cannot even install 10.5 on it.

    She has to sync her iPhone, to do updates for the iPhone, on my old Toshiba notebook, running an old copy of WinXP Home.

    She is not going to buy a brand new iBook/MacBook, just to sync her phone. I would like to be able to run this software, on her iBook, for when my old Toshiba eats it, which is probably soon. RIM, do you really need to require Mac OS 10.5.5?

  • Michael

    What’s up with it requiring Mac OS 10.5.5? My wife is already steamed about this – she has an iPhone, and can not sync with her iBook, because it is a few years old. Her iBook will not even run the 10.5.5 OS, because it requires a certain speed of processor. You cannot even install 10.5 on it.

    She has to sync her iPhone, to do updates for the iPhone, on my old Toshiba notebook, running an old copy of WinXP Home.

    She is not going to buy a brand new iBook/MacBook, just to sync her phone. I would like to be able to run this software, on her iBook, for when my old Toshiba eats it, which is probably soon. RIM, do you really need to require Mac OS 10.5.5?

  • Robert

    I’ve been eagerly awaiting this for YEARS! I think I actually have wood! Now please RIM, don’t make it suck.

  • Robert

    I’ve been eagerly awaiting this for YEARS! I think I actually have wood! Now please RIM, don’t make it suck.

  • http://twitter.com/N_Sampogna/statuses/2747693931 N_Sampogna (Nicky Sampogna)

    RT @jordanweil: RT @BlackBerryCool: Preview the latest BlackBerry Desktop Manager for Mac http://bit.ly/o1y1T #blackberry #apple #iPhone

  • http://twitter.com/mcamhi/statuses/2747819418 mcamhi (Marcelo Camhi)

    RT @BlackBerryCool: Preview the latest BlackBerry Desktop Manager for Mac http://bit.ly/o1y1T | POR FIIIIIINNNNNNNN!!!!!!!!!!!!

  • http://twitter.com/mcamhi/statuses/2747819418 mcamhi (Marcelo Camhi)

    RT @BlackBerryCool: Preview the latest BlackBerry Desktop Manager for Mac http://bit.ly/o1y1T | POR FIIIIIINNNNNNNN!!!!!!!!!!!!

  • http://twitter.com/mcamhi/statuses/2748090852 mcamhi (Marcelo Camhi)

    Por fin para los usuarios Mac | BlackBerry, RIM va a liberar el BlackBerry Desktop Manager para Mac!!! /Graciaaas!!! http://bit.ly/o1y1T

  • http://twitter.com/shifterfast/statuses/2750747953 shifterfast (Ricky Harrison)

    RT @BlackBerryCool: Preview the latest BlackBerry Desktop Manager for Mac http://bit.ly/o1y1T

  • Chamara

    I was waiting for this many years, Please Make this available sooooooon

  • Chamara

    I was waiting for this many years, Please Make this available sooooooon

  • aZubaid

    This is great…but can we sync pictures from our iTunes or only music? RIM please add pictures sync if not. Would be very useful and would really give me no reason what so ever to get an iphone.

  • aZubaid

    This is great…but can we sync pictures from our iTunes or only music? RIM please add pictures sync if not. Would be very useful and would really give me no reason what so ever to get an iphone.

  • aZubaid

    This is great…but can we sync pictures from our iTunes or only music? RIM please add pictures sync if not. Would be very useful and would really give me no reason what so ever to get an iphone.

  • http://none aZubaid

    This is great…but can we sync pictures from our iTunes or only music? RIM please add pictures sync if not. Would be very useful and would really give me no reason what so ever to get an iphone.

  • CrackBaby®

    I have been syncing my calendar and contacts to my Mac via Google for some time, and am surprised that there is still a demand for batchsyncing via cable (as websync is realtime in contrast to syncing every time I get home). My phone (storm) even has the posibility to update software over the air, yet there are never any updates available. Strange, as there have been two major updates installable via cable since I got the phone, and there are new versions of apps all the time.
    The only use I would have for a sync app for the mac would be to update my BB-OS, as windows machines are a dying breed. I know only one guy who actually has one, and he lives on the country side (yes he is a gamer).

    Why not focus more on websync, as all BB-phones have internet? Browsing through my mp3 collection on my home computer over the net would be tremendous. and it would certainly impress the iphones owners.

    Apart from that, I am very happy to see that RIM does give som effort to provide mac users with the product they paid for.

  • CrackBaby®

    I have been syncing my calendar and contacts to my Mac via Google for some time, and am surprised that there is still a demand for batchsyncing via cable (as websync is realtime in contrast to syncing every time I get home). My phone (storm) even has the posibility to update software over the air, yet there are never any updates available. Strange, as there have been two major updates installable via cable since I got the phone, and there are new versions of apps all the time.
    The only use I would have for a sync app for the mac would be to update my BB-OS, as windows machines are a dying breed. I know only one guy who actually has one, and he lives on the country side (yes he is a gamer).

    Why not focus more on websync, as all BB-phones have internet? Browsing through my mp3 collection on my home computer over the net would be tremendous. and it would certainly impress the iphones owners.

    Apart from that, I am very happy to see that RIM does give som effort to provide mac users with the product they paid for.

  • http://thisisthree.com/ Donald Kelly

    @Michael

    Mac OS X 10.5 is required for many of the UI elements you see RIM using with BlackBerry Desktop Manager for Mac, A lot of it has things to do with the system “core” elements like CoreAnimation etc etc, Plenty of applications require 10.5, from Photoshop, to things like Word:Mac 2009.

    10.5.5 updated a bunch of the communication elements and USB drivers for Mac users, these changed some of how communications over USB are carried out.

    It is the fact that many computers are unable to run various applications, The fact that an iBook can’t run Leopard isn’t really surprising. The iBook is going on 3-4 years old, iBooks’ also use the prior generation of processors, PowerPC G4′s and G3′s, when Apple changed to intel, they provided developers the option to create dual-binary applications, which worked for both platforms, The issue with this being that additional code was required, and anytime you require additional code, application efficiency and speed begin to drop, and overall application size begins to rise.

    So being honest, Yes, they really did need to require 10.5 to be a minimum specification to run this application, many of the things this app requires to even function are 10.5 only features, and those running 10.3/10.4 are in need of an upgrade anyway.

  • http://thisisthree.com Donald Kelly

    @Michael

    Mac OS X 10.5 is required for many of the UI elements you see RIM using with BlackBerry Desktop Manager for Mac, A lot of it has things to do with the system “core” elements like CoreAnimation etc etc, Plenty of applications require 10.5, from Photoshop, to things like Word:Mac 2009.

    10.5.5 updated a bunch of the communication elements and USB drivers for Mac users, these changed some of how communications over USB are carried out.

    It is the fact that many computers are unable to run various applications, The fact that an iBook can’t run Leopard isn’t really surprising. The iBook is going on 3-4 years old, iBooks’ also use the prior generation of processors, PowerPC G4′s and G3′s, when Apple changed to intel, they provided developers the option to create dual-binary applications, which worked for both platforms, The issue with this being that additional code was required, and anytime you require additional code, application efficiency and speed begin to drop, and overall application size begins to rise.

    So being honest, Yes, they really did need to require 10.5 to be a minimum specification to run this application, many of the things this app requires to even function are 10.5 only features, and those running 10.3/10.4 are in need of an upgrade anyway.

  • X T Kuzy Chukson

    Notify me if there is any updates on blackberry desktop manager or latest softwares. Thanks!

  • X T Kuzy Chukson

    Notify me if there is any updates on blackberry desktop manager or latest softwares. Thanks!

  • Oliver

    What about 10.6 Snow Leopard? That is do out in September too, and I plan on upgrading. Anyone know if it will work with Snow Leopard?

  • Oliver

    What about 10.6 Snow Leopard? That is do out in September too, and I plan on upgrading. Anyone know if it will work with Snow Leopard?

  • Oliver

    What about 10.6 Snow Leopard? That is do out in September too, and I plan on upgrading. Anyone know if it will work with Snow Leopard?

  • R.M

    ahhh .. still dying for this to be releaased :(

  • R.M

    ahhh .. still dying for this to be releaased :(

  • David

    I am dying without this BB desktop mgr. Is there an actual date it will be released? It’s September! :)

  • David

    I am dying without this BB desktop mgr. Is there an actual date it will be released? It’s September! :)

  • David

    I am dying without this BB desktop mgr. Is there an actual date it will be released? It’s September! :)

  • Waqar

    I agree with David. Now September – Where is this cool new kit. Like others I am dying without this!!

  • Waqar

    I agree with David. Now September – Where is this cool new kit. Like others I am dying without this!!

  • Mizamura

    Where issit??? I’m waiting eagerly for the release man!

  • Mizamura

    Where issit??? I’m waiting eagerly for the release man!

  • andy

    hi..good morning..just bought the bold one today. using iphone before, having problems with copying contacts//:( i hope this can help, when is it coming ,,its already september

  • andy

    hi..good morning..just bought the bold one today. using iphone before, having problems with copying contacts//:( i hope this can help, when is it coming ,,its already september

  • Anonymous

    This article describes the application and provides a link to version 1.0 at the bottom:

    http://www.sfgate.com/cgi-bin/article.cgi?f=/g/a/2009/09/03/urnidgns002570F3005978D885257626006594E9.DTL

  • Patrick

    This article describes the application and provides a link to version 1.0 at the bottom:

    http://www.sfgate.com/cgi-bin/article.cgi?f=/g/a/2009/09/03/urnidgns002570F3005978D885257626006594E9.DTL

  • Darren

    Gotta have 10.5.5 huh…
    If me and my wife had the money to upgrade to two Macs that would comfortably run 10.5.5… then I’d probably just shell out the cash for Iphones.

    I can’t believe that this little device manager app is gonna be so powerful it’s gonna draw all the power that 10.5.5 offers :)

  • Darren

    Gotta have 10.5.5 huh…
    If me and my wife had the money to upgrade to two Macs that would comfortably run 10.5.5… then I’d probably just shell out the cash for Iphones.

    I can’t believe that this little device manager app is gonna be so powerful it’s gonna draw all the power that 10.5.5 offers :)

  • Darren

    Gotta have 10.5.5 huh…
    If me and my wife had the money to upgrade to two Macs that would comfortably run 10.5.5… then I’d probably just shell out the cash for Iphones.

    I can’t believe that this little device manager app is gonna be so powerful it’s gonna draw all the power that 10.5.5 offers :)

  • Nadir

    With great expectations I have run the beta on my system – only to find that there is a bug with the synch of contacts

    on my 8900 ONLY one number per contact will transfer – its a huge disappointment

  • Nadir

    With great expectations I have run the beta on my system – only to find that there is a bug with the synch of contacts

    on my 8900 ONLY one number per contact will transfer – its a huge disappointment

  • Nadir

    With great expectations I have run the beta on my system – only to find that there is a bug with the synch of contacts

    on my 8900 ONLY one number per contact will transfer – its a huge disappointment