Reminder: RIM promised OS 5 before the end of 2009

72 Comments

download-blackberry-os-5-0-0-90

Back at WES 2009, RIM put out a statement saying that OS 5, “will follow before the end of the year.” Most of us in the BlackBerry Nation have been expecting this software to launch around this time and we’re all wondering where it is.

While the software will be coming out with the BlackBerry Bold 9700 and the Storm 2 9550/9520, it isn’t clear when older BlackBerry devices will be privy to the upgrade.

At the very least, we know you won’t have to wait longer than January 1st, 2010.

The official statement from RIM is as follows:

“The roll out process has begun for BlackBerry Device Software 5.0 with the recent beta release of BlackBerry JDE 5.0 (BlackBerry Java Development Environment 5.0) to BlackBerry Developer Zone at www.blackberry.com/developers to prepare the BlackBerry developer community for pending device software releases. As can be expected, BlackBerry Device Software 5.0 will follow before the end of the year, as referenced in the “RIM Launches BlackBerry Enterprise Server 5.0″ press release that was issued at WES 2009 (http://press.rim.com/release.jsp?id=2309).”

Just out of curiosity, what device do you have and what OS are you currently running?

[Via]

  • FatherB

    I have the Curve 8310 and am running 4.5.0.161 Any chance that OS 5.0 will be released for this Berry?

  • Katherine

    I’ve got a Curve 8310 and I’m running OS 4.5.
    I’d love to be able to upgrade the OS.. I heard rumours about the OS 5.0 being available for the 83XXs but I’m trying not to get my hopes up in case it doesn’t happen….

  • Katherine

    I’ve got a Curve 8310 and I’m running OS 4.5.
    I’d love to be able to upgrade the OS.. I heard rumours about the OS 5.0 being available for the 83XXs but I’m trying not to get my hopes up in case it doesn’t happen….

  • http://twitter.com/takesea/statuses/4042194708 takesea (Takeshi Nishimoto)

    Flash????????????????????????????????????????????RT @BlackBerryCool: Reminder: RIM promised OS 5 before the end of 2009 http://bit.ly/2vtb1R

  • http://twitter.com/still_smoking/statuses/4042884164 still_smoking (Sean and Mel)

    RT @BlackBerryCool: Reminder: RIM promised OS 5 before the end of 2009 http://bit.ly/2vtb1R http://myloc.me/F8QZ

  • http://twitter.com/still_smoking/statuses/4042884164 still_smoking (Sean and Mel)

    RT @BlackBerryCool: Reminder: RIM promised OS 5 before the end of 2009 http://bit.ly/2vtb1R http://myloc.me/F8QZ

  • charles

    Bold 9000, 5.0.0.190

  • charles

    Bold 9000, 5.0.0.190

  • http://twitter.com/artsk/statuses/4047473504 artsk (Art Khonaim)

    RT @BlackBerryCool: Reminder: RIM promised OS 5 before the end of 2009 http://bit.ly/2vtb1R #fb

  • http://twitter.com/artsk/statuses/4047473504 artsk (Art Khonaim)

    RT @BlackBerryCool: Reminder: RIM promised OS 5 before the end of 2009 http://bit.ly/2vtb1R #fb

  • http://twitter.com/artsk/statuses/4047473504 artsk (Art Khonaim)

    RT @BlackBerryCool: Reminder: RIM promised OS 5 before the end of 2009 http://bit.ly/2vtb1R #fb

  • http://twitter.com/mariazet/statuses/4048619410 mariazet (Marcin Blaszczak)

    RT: @port3101 RT @BlackBerryCool: Reminder: RIM promised OS 5 before the end of 2009 http://bit.ly/2vtb1R

  • Franky

    Devcon isn’t until November. I wouldn’t expect them to release something like this before then.

  • Franky

    Devcon isn’t until November. I wouldn’t expect them to release something like this before then.

  • M Clark

    I hope this is available for the Curve 8330. Having a browser that is not ajax capable is bad. An update for the BB browser to support Ajax is overdue in my opinion. If one has to upgrade to a different BB Model to get OS 5, then RIM is emulating Palm which is not good for the BB community. If OS 5 cannot be installed on most newer Curve models, I truly hope BB issues an updated browser which supports Ajax for older BB models. (Curve 8330 isn’t that “old” as Verizon is still selling them and I just got one.)

  • M Clark

    I hope this is available for the Curve 8330. Having a browser that is not ajax capable is bad. An update for the BB browser to support Ajax is overdue in my opinion. If one has to upgrade to a different BB Model to get OS 5, then RIM is emulating Palm which is not good for the BB community. If OS 5 cannot be installed on most newer Curve models, I truly hope BB issues an updated browser which supports Ajax for older BB models. (Curve 8330 isn’t that “old” as Verizon is still selling them and I just got one.)

  • VF

    FUCKYOURASSLITTTLEBITCHSONOFADITCHFUCKINGBIGCOCKINMYASS

  • Axd

    frustrated much?