Facebook for BlackBerry gets updated to 1.7

20 Comments

Facebook17

The official Facebook app has been updated to version 1.7.0.18 and it’s available for download in App World.

The Facebook application is unique in that it was developed by RIM in order to take advantage of APIs that aren’t available to third party developers. This gives the app much needed integration with your BlackBerry.

The latest version of Facebook has the following improvements:

  • News Feed Support – The ability to set the News Feed as the landing page.
  • News Feed Filters – The ability to toggle between ‘News Feed, Status Updates, Photos and Links.
  • Caching Improvements – The application uses the device memory more efficiently.
  • Feed Pre-fetching – The user will not be required to wait while their Facebook Feeds are updated.
  • View Profile Menu Option – Clients may easily view their own profile by selecting ‘View my Profile’ from the menu.

While the update brings some improvements in the way of efficiency, it is still seriously lacking when it comes to the user interface. Many users have complained that the icons are designed such that you need the icon caption text to tell you what you’re looking at. The app also has a less than stellar review in App World, with only about 2 and a half stars.

  • rob

    They have done it again. Facebook 1.7 for BB gives the same ‘data connection error” as 1.6 did. The only way out for many users was to go back to 1.5. WTF cant RIM get this right? Iphone apps simply dont have these stupid issues. Another RIM inspired waste of my time. And yes I have tried battery pull, resetting permissions, turning on APN settings, reinstalltion, HRT registering, deletion of the desktop [IPPP} service book + battery pull, nothing works. Idiots.

  • rob

    They have done it again. Facebook 1.7 for BB gives the same ‘data connection error” as 1.6 did. The only way out for many users was to go back to 1.5. WTF cant RIM get this right? Iphone apps simply dont have these stupid issues. Another RIM inspired waste of my time. And yes I have tried battery pull, resetting permissions, turning on APN settings, reinstalltion, HRT registering, deletion of the desktop [IPPP} service book + battery pull, nothing works. Idiots.

  • James

    Facebook 1.7 ‘data connection error” Its not hard to test before release!!!! COME ON RIM!!!!! SORT IT OUT.

  • http://SameasRob James

    Facebook 1.7 ‘data connection error” Its not hard to test before release!!!! COME ON RIM!!!!! SORT IT OUT.

  • Carina

    So with v1.7 I have the “ABILITY” to set the News Feed as the landing page on my Blackberry.

    Anyone out there who can tell me how to set the landing page to Status Updates (or anything other than News Feed!)?

    Yech.

  • Carina

    So with v1.7 I have the “ABILITY” to set the News Feed as the landing page on my Blackberry.

    Anyone out there who can tell me how to set the landing page to Status Updates (or anything other than News Feed!)?

    Yech.

  • matt

    same data error issue here on the bold: 1.6 worked fine until the new “improved” upgrade”. but the missus new curve works fine on 1.7!…done the same as rob on the bold with the settings, delete service books delete app etc no joy! arrggghh!

    and i dont give a monkeys about newsfeed! status updates, abilty to upload pics was fine. going back to older version!!

  • matt

    same data error issue here on the bold: 1.6 worked fine until the new “improved” upgrade”. but the missus new curve works fine on 1.7!…done the same as rob on the bold with the settings, delete service books delete app etc no joy! arrggghh!

    and i dont give a monkeys about newsfeed! status updates, abilty to upload pics was fine. going back to older version!!

  • http://na matt

    same data error issue here on the bold: 1.6 worked fine until the new “improved” upgrade”. but the missus new curve works fine on 1.7!…done the same as rob on the bold with the settings, delete service books delete app etc no joy! arrggghh!

    and i dont give a monkeys about newsfeed! status updates, abilty to upload pics was fine. going back to older version!!

  • Carina

    Well, I did an uninstall of v1.7, trying to reinstall 1.6 and now I get an error that “your device does not meet the system requirements that are needed to support Facebook”.

    I pulled the battery, double checked the memory (there was enough before, now can there not be enough now?).

    More trouble than it’s worth. I’m ready to move on without mobile Facebook.

  • Carina

    Well, I did an uninstall of v1.7, trying to reinstall 1.6 and now I get an error that “your device does not meet the system requirements that are needed to support Facebook”.

    I pulled the battery, double checked the memory (there was enough before, now can there not be enough now?).

    More trouble than it’s worth. I’m ready to move on without mobile Facebook.

  • Kay

    I have the same complaint as Carina. Honestly I am getting tired of this. I pay good money for the phone and the service then they go and give us bug filled applications and no clear way to fix them. I just want 1.6 back, I thought I hated it until 1.7! (sigh)

  • Kay

    I have the same complaint as Carina. Honestly I am getting tired of this. I pay good money for the phone and the service then they go and give us bug filled applications and no clear way to fix them. I just want 1.6 back, I thought I hated it until 1.7! (sigh)

  • Kay

    I have the same complaint as Carina. Honestly I am getting tired of this. I pay good money for the phone and the service then they go and give us bug filled applications and no clear way to fix them. I just want 1.6 back, I thought I hated it until 1.7! (sigh)

  • ashley

    Had a BB now for 2 months, every other App. Works fine. Facebook always loses the server connection and shuts down for 2 or 3 days and now I can’t even view status updates on friends pages they come up as “a{:}” or something like that. Very frustrating, ready to delete the Appm

  • ashley

    Had a BB now for 2 months, every other App. Works fine. Facebook always loses the server connection and shuts down for 2 or 3 days and now I can’t even view status updates on friends pages they come up as “a{:}” or something like that. Very frustrating, ready to delete the Appm

  • Kush

    All I want is my Facebook 1.6 back. These bastards at RIM launched the 1.7 and when they f**ked that up, they cut off access to the download links for the 1.6 verion that worked fine before, WTF are these so called new “system requirements” that I don’t have? Huh?

    P.S.- isn’t it weird that an old version of an app requires more shit and resources that the newer version. What BOLLOCKS

  • Kush

    All I want is my Facebook 1.6 back. These bastards at RIM launched the 1.7 and when they f**ked that up, they cut off access to the download links for the 1.6 verion that worked fine before, WTF are these so called new “system requirements” that I don’t have? Huh?

    P.S.- isn’t it weird that an old version of an app requires more shit and resources that the newer version. What BOLLOCKS

  • Kush

    All I want is my Facebook 1.6 back. These bastards at RIM launched the 1.7 and when they f**ked that up, they cut off access to the download links for the 1.6 verion that worked fine before, WTF are these so called new “system requirements” that I don’t have? Huh?

    P.S.- isn’t it weird that an old version of an app requires more shit and resources that the newer version. What BOLLOCKS

  • Kush

    All I want is my Facebook 1.6 back. These bastards at RIM launched the 1.7 and when they f**ked that up, they cut off access to the download links for the 1.6 verion that worked fine before, WTF are these so called new “system requirements” that I don’t have? Huh?

    P.S.- isn’t it weird that an old version of an app requires more shit and resources that the newer version. What BOLLOCKS