BlackBerry OS 5 themes bug on 9530 and maybe Storm 2

70 Comments

storm_9530_os5_theme_bug

I have loaded the official OS 5.0.0.328 on my BlackBerry Storm 9530 and my themes are broken. There has been some buzz about this in the forums and I’ve tested the theory using an Elecite theme on my Verizon 9530.

What happens when you load a theme with the latest official OS 5 build, is very worrying. If you go into landscape mode from the homepage, and scroll, you get the dragging window effect (see the above screenshot). Also, some of the buttons in my theme, such as the “media” button, no longer work.

The Verizon BlackBerry Storm 2 is shipping tomorrow with OS 5.0.0.320 (according to the device I’m holding in my hands now) and now I’m worried the whole themes business is crushed for Storm users.

Stay tuned as we test this themes bug on the Storm 2.

  • http://www.twitter.com/djgmac DJ G.MAC!

    Whew! I thought it was just me!

  • http://www.twitter.com/djgmac DJ G.MAC!

    Whew! I thought it was just me!

  • Shawn

    same problem here.

  • Shawn

    same problem here.

  • wahtx

    Same thing here!!! iPhone theme is no more!!!!

  • wahtx

    Same thing here!!! iPhone theme is no more!!!!

  • Jon

    this issue can be resolved, as posted on crackberry.com forums by wiseguy77:
    “step1: obviously load the theme step2: do not use the theme wall paper change it! this is where the issue lies. step3: after changing your wall paper to something other than the theme default go to options>themes>open the little blue box to the right of the active theme. now select the layou option and change the row settings from 2 rows to one row then back to two with out leaving the theme screen, and wala your theme will not longer show the white borders when in landscape mode only bummer is that you have to repeat step 3 each time you change themes or reboot you phone as long as the wallpaper is not the theme default i guarantee you this will work.”

  • Jon

    this issue can be resolved, as posted on crackberry.com forums by wiseguy77:
    “step1: obviously load the theme step2: do not use the theme wall paper change it! this is where the issue lies. step3: after changing your wall paper to something other than the theme default go to options>themes>open the little blue box to the right of the active theme. now select the layou option and change the row settings from 2 rows to one row then back to two with out leaving the theme screen, and wala your theme will not longer show the white borders when in landscape mode only bummer is that you have to repeat step 3 each time you change themes or reboot you phone as long as the wallpaper is not the theme default i guarantee you this will work.”

  • Jon

    this issue can be resolved, as posted on crackberry.com forums by wiseguy77:
    “step1: obviously load the theme step2: do not use the theme wall paper change it! this is where the issue lies. step3: after changing your wall paper to something other than the theme default go to options>themes>open the little blue box to the right of the active theme. now select the layou option and change the row settings from 2 rows to one row then back to two with out leaving the theme screen, and wala your theme will not longer show the white borders when in landscape mode only bummer is that you have to repeat step 3 each time you change themes or reboot you phone as long as the wallpaper is not the theme default i guarantee you this will work.”

  • Nathan

    temporary fix:

    1. In landscape mode, hit blackberry button, select options and change wallpaper from the theme default
    2. Back in options, select layout, change to Today mode, save and close out
    3. Go back to options, select layout and change back to 2 rows

    Theme should now work properly until next reboot

  • Nathan

    temporary fix:

    1. In landscape mode, hit blackberry button, select options and change wallpaper from the theme default
    2. Back in options, select layout, change to Today mode, save and close out
    3. Go back to options, select layout and change back to 2 rows

    Theme should now work properly until next reboot

  • Nathan

    temporary fix:

    1. In landscape mode, hit blackberry button, select options and change wallpaper from the theme default
    2. Back in options, select layout, change to Today mode, save and close out
    3. Go back to options, select layout and change back to 2 rows

    Theme should now work properly until next reboot

  • Chris

    I heard there was a fix for this. Haven’t tried it yet, but if you go to options > advanced options > accessibility. Change grid layout to 2×2. Save. Then change it back to 4×4. Once again, I haven’t tried it yet because I heard about it after deleting my themes.

  • Chris

    I heard there was a fix for this. Haven’t tried it yet, but if you go to options > advanced options > accessibility. Change grid layout to 2×2. Save. Then change it back to 4×4. Once again, I haven’t tried it yet because I heard about it after deleting my themes.

  • Chris

    *…or change it back to default.

  • Chris

    *…or change it back to default.

  • Chris

    *…or change it back to default.

  • DavidB

    I can’t say I’m surprised really. Launching OS 5.0 is much like launching a whole new device. Themes didn’t work for several weeks after Tour launch and it was several months before Curve 8900 with OS 4.6.1 had Themes available. I suspect it is just a fluke that they even word at all. I don’t share your doom and gloom though Kyle.

    Is there even a Plazmic 5.0 available yet?

  • DavidB

    I can’t say I’m surprised really. Launching OS 5.0 is much like launching a whole new device. Themes didn’t work for several weeks after Tour launch and it was several months before Curve 8900 with OS 4.6.1 had Themes available. I suspect it is just a fluke that they even word at all. I don’t share your doom and gloom though Kyle.

    Is there even a Plazmic 5.0 available yet?

  • Chris

    Nevermind my previous posts. I tried it and it didn’t work. Sorry for wasting your time!

  • Chris

    Nevermind my previous posts. I tried it and it didn’t work. Sorry for wasting your time!

  • Chris

    Nevermind my previous posts. I tried it and it didn’t work. Sorry for wasting your time!

  • jennifer

    yeah same here. i just updated mysoftware and the theme i have is doing the same thing. sucks but like you said davidb launching the os 5 is like releasing a new device. now every one had to catch up to the new system. I like the new os though becasue it seems like my phone doesn’t drag as much but my quick pull application isn’t working right so im trying to redownload it to see how it works.

  • jennifer

    yeah same here. i just updated mysoftware and the theme i have is doing the same thing. sucks but like you said davidb launching the os 5 is like releasing a new device. now every one had to catch up to the new system. I like the new os though becasue it seems like my phone doesn’t drag as much but my quick pull application isn’t working right so im trying to redownload it to see how it works.

  • Lisa Shaver

    So will there be a fix for this problem or will this becomea pain in the butt…Hate that I have themes I paid for that the new os and landscape want function right with…

  • Lisa Shaver

    So will there be a fix for this problem or will this becomea pain in the butt…Hate that I have themes I paid for that the new os and landscape want function right with…

  • Lisa Shaver

    So will there be a fix for this problem or will this becomea pain in the butt…Hate that I have themes I paid for that the new os and landscape want function right with…

  • MarkinDetroit

    I have the same problem.
    I was able to “fix” it by setting the main screen layout to “Today” while in portrait mode. Save it, then check the landscape mode. It should be okay.
    Rotate back to portrait, open the layout and change it back to “2 rows”, save it, and things should look okay.
    It should stay this way until you reboot the phone.

  • MarkinDetroit

    I have the same problem.
    I was able to “fix” it by setting the main screen layout to “Today” while in portrait mode. Save it, then check the landscape mode. It should be okay.
    Rotate back to portrait, open the layout and change it back to “2 rows”, save it, and things should look okay.
    It should stay this way until you reboot the phone.

  • Shankeith

    here the way i fixed it guys (really odd to as well):
    at the icons section hit the BB button
    select options to get the theme options
    select layout and set it to today
    next close this and rotate the screen to landscape
    now hit the BB button again to get the theme options again
    select layout and set it back to 2 rows

    DONE

    your welcome

  • Shankeith

    here the way i fixed it guys (really odd to as well):
    at the icons section hit the BB button
    select options to get the theme options
    select layout and set it to today
    next close this and rotate the screen to landscape
    now hit the BB button again to get the theme options again
    select layout and set it back to 2 rows

    DONE

    your welcome

  • Brian

    Thank you to everyone for their input. It has not made me feel totally lost with the 5.0 OS for Storm. However, someone might want to explain our collective concerns to Verizon’s tech support or other relevant providers.

    When talking to Verizon today on the phone, and in person, I was told to merely “backup my files” and “just restore everything”. Not an option I was in favor of given certain paid applications that could potentially be lost. To add to the frustration when Verizon’s tech department saw the white blurred boarders (thank you for the illustration above); with little explanation they gave me a new BB Storm with a factory installed 5.0 OS. To my dismay, nothing was corrected and there remained little capability for my theme, like your own to working accordingly.

    So, this issue is not the user but rather the 5.0 OS it’s self that restricts utilizing a theme’s layout properly. Perhaps this problem will be corrected in time? Or at least, themes will be released taking into account these glitches and meet 5.0 OS head on. Until than, spread the word to other users and your phone provider what we’ve experienced. Because I don’t foresee a lasting independent solution to rectify this matter or for 5.0 OS themes to be released anytime soon.

  • Brian

    Thank you to everyone for their input. It has not made me feel totally lost with the 5.0 OS for Storm. However, someone might want to explain our collective concerns to Verizon’s tech support or other relevant providers.

    When talking to Verizon today on the phone, and in person, I was told to merely “backup my files” and “just restore everything”. Not an option I was in favor of given certain paid applications that could potentially be lost. To add to the frustration when Verizon’s tech department saw the white blurred boarders (thank you for the illustration above); with little explanation they gave me a new BB Storm with a factory installed 5.0 OS. To my dismay, nothing was corrected and there remained little capability for my theme, like your own to working accordingly.

    So, this issue is not the user but rather the 5.0 OS it’s self that restricts utilizing a theme’s layout properly. Perhaps this problem will be corrected in time? Or at least, themes will be released taking into account these glitches and meet 5.0 OS head on. Until than, spread the word to other users and your phone provider what we’ve experienced. Because I don’t foresee a lasting independent solution to rectify this matter or for 5.0 OS themes to be released anytime soon.

  • Brian

    Thank you to everyone for their input. It has not made me feel totally lost with the 5.0 OS for Storm. However, someone might want to explain our collective concerns to Verizon’s tech support or other relevant providers.

    When talking to Verizon today on the phone, and in person, I was told to merely “backup my files” and “just restore everything”. Not an option I was in favor of given certain paid applications that could potentially be lost. To add to the frustration when Verizon’s tech department saw the white blurred boarders (thank you for the illustration above); with little explanation they gave me a new BB Storm with a factory installed 5.0 OS. To my dismay, nothing was corrected and there remained little capability for my theme, like your own to working accordingly.

    So, this issue is not the user but rather the 5.0 OS it’s self that restricts utilizing a theme’s layout properly. Perhaps this problem will be corrected in time? Or at least, themes will be released taking into account these glitches and meet 5.0 OS head on. Until than, spread the word to other users and your phone provider what we’ve experienced. Because I don’t foresee a lasting independent solution to rectify this matter or for 5.0 OS themes to be released anytime soon.

  • Mikey

    i tried several ‘SOLUTIONS’ recommended above. NONE WORK! so just change ur theme back to the default theme and live with it until your theme developers update their themes for the 5.0 OS. This seems to the consensus among several websites at which i have researched this issue. wish i had some better news or a REAL solution.

  • Mikey

    i tried several ‘SOLUTIONS’ recommended above. NONE WORK! so just change ur theme back to the default theme and live with it until your theme developers update their themes for the 5.0 OS. This seems to the consensus among several websites at which i have researched this issue. wish i had some better news or a REAL solution.

  • Mikey

    i tried several ‘SOLUTIONS’ recommended above. NONE WORK! so just change ur theme back to the default theme and live with it until your theme developers update their themes for the 5.0 OS. This seems to the consensus among several websites at which i have researched this issue. wish i had some better news or a REAL solution.

  • DavidB

    @Mikey: I agree with you. It was this way when Bold launched, when Flip launched, when 8900 and 9630 launched, this is really not new to RIM launches. You would think as long as OS 5.0 has been in development that RIM would have had their shxt together but sadly they don’t. Temporary boot to boot hacks to make certain themes work okay is ok if you just MUST have a theme NOW. But Joe BLACKBERRY user isn’t gonna bother with that. Heck most don’t even know what a theme IS and even when App World starts selling themes it is still not gonna vastly increase public knowledge of themes. I think the best action is gonna be just like with all those other launches without theme support let’s just wait it out for either RIM to fix the OS (if its an OS bug) or wait for Plazmic 5.0. I suspect just like with 4.7.1, once the CDK is updated there will be TONS of themes hitting the theme sites/stores and App World.

  • DavidB

    @Mikey: I agree with you. It was this way when Bold launched, when Flip launched, when 8900 and 9630 launched, this is really not new to RIM launches. You would think as long as OS 5.0 has been in development that RIM would have had their shxt together but sadly they don’t. Temporary boot to boot hacks to make certain themes work okay is ok if you just MUST have a theme NOW. But Joe BLACKBERRY user isn’t gonna bother with that. Heck most don’t even know what a theme IS and even when App World starts selling themes it is still not gonna vastly increase public knowledge of themes. I think the best action is gonna be just like with all those other launches without theme support let’s just wait it out for either RIM to fix the OS (if its an OS bug) or wait for Plazmic 5.0. I suspect just like with 4.7.1, once the CDK is updated there will be TONS of themes hitting the theme sites/stores and App World.

  • DavidB

    @Mikey: I agree with you. It was this way when Bold launched, when Flip launched, when 8900 and 9630 launched, this is really not new to RIM launches. You would think as long as OS 5.0 has been in development that RIM would have had their shxt together but sadly they don’t. Temporary boot to boot hacks to make certain themes work okay is ok if you just MUST have a theme NOW. But Joe BLACKBERRY user isn’t gonna bother with that. Heck most don’t even know what a theme IS and even when App World starts selling themes it is still not gonna vastly increase public knowledge of themes. I think the best action is gonna be just like with all those other launches without theme support let’s just wait it out for either RIM to fix the OS (if its an OS bug) or wait for Plazmic 5.0. I suspect just like with 4.7.1, once the CDK is updated there will be TONS of themes hitting the theme sites/stores and App World.

  • stevec

    how can I get the txt msg’s to STOP filling in words when I am typing. It’s killing me.

  • stevec

    how can I get the txt msg’s to STOP filling in words when I am typing. It’s killing me.

  • Christy

    I experienced the same thing tonight when my husband and i upgraded our software. Even premium purchased themes no longer work after the upgrade. When turned to landscape mode our phones look just like the phone in the above pic. So frustrating! just another frustration for storm users!
    i so hope they fix this. i love my themes!

  • Christy

    I experienced the same thing tonight when my husband and i upgraded our software. Even premium purchased themes no longer work after the upgrade. When turned to landscape mode our phones look just like the phone in the above pic. So frustrating! just another frustration for storm users!
    i so hope they fix this. i love my themes!

  • http://www.thecarbar.net/ Adam

    I had the same problem with the Seattle seahawk theme what a FAIL.org

  • http://www.thecarbar.net Adam

    I had the same problem with the Seattle seahawk theme what a FAIL.org

  • DavidB

    @stevec: options…Language and Text Input… The change input style to auto correct instead of word completion.

    So…anyone with a Storm2 try a 3rd party theme in landscape?

  • DavidB

    @stevec: options…Language and Text Input… The change input style to auto correct instead of word completion.

    So…anyone with a Storm2 try a 3rd party theme in landscape?

  • DavidB

    @stevec: options…Language and Text Input… The change input style to auto correct instead of word completion.

    So…anyone with a Storm2 try a 3rd party theme in landscape?

  • DavidB

    @stevec: options…Language and Text Input… The change input style to auto correct instead of word completion.

    So…anyone with a Storm2 try a 3rd party theme in landscape?